Xbox One Mass Effect Legendary Digital XBox One ME2 Not Installing

Glen Schmidt

New Member
May 26, 2021
I purchased the New Mass Effect Legendary collection for XBox One. I just played through/completed ME1 (approx 40+ hours gameplay). I went to play ME2 and it informs me it needs to install. I start the process and it then tells me there is an update. I let the update run for a few hours and then it starts the install process for ME2. It goes very slow over a period of hours and only gets to 11% and hangs. I tried restarting the process (it went through the update again for some reason) multiple times. Tried a complete console reset. Haven't tried to uninstall because I am afraid of losing my Save from ME1 that ports over to ME2. It has never gotten beyond 16%! I have been trying for the last 14 hours. Anyone know how to resolve this? If not, I'm going to have to return the game and I don't want to. Mass Effect is my favorite SciFi series and I have owned them all for multiple platforms. I was really looking forward to this collection (even if it's missing Pinnacle Station).
I ended up trying a few times more and once after letting it run all night and I got up to find it had stuck at around 60% I did a hard reboot to try again ... only to find ME2 was already installed? Weird. Maybe it was installed all along and my console somehow didn't think it was? I haven't tried to install ME3 yet. I'm a bit nervous to try.