Original Xbox Which softmod is on my XBOX?


New Member
Apr 8, 2012
Hello! I am new to this forum so sorry if I've made any mistakes in this post. So, I've got an original XBOX, second-hand. I loaded the console, and it loaded as a normal XBOX, but without the XBOX live menu option (Network plugged in, working fine). So I tried softmodding it by copying SID 4 Installer and Splinter Cell save for SID 4 to the HDD and then loading the game. I loaded the LINUX profile and chose CHECK POINTS. It loded the SID 4 installer and I made an EEPROM backup and tried to make an MS backup, but it said I already had a softmod. (I didn't think I did!!!) So I restarted and tried loading with the eject key, (no softmod), power button, (nope), power then hold start, (Ditto). So I basically need to know if I have got a softmod installed from the previous owner, and if I have, how to activate it as it won't let me install without backing up the C: drive. (Using a PAL v1.1 XBOX original.) Please help me get to a solution, and happy easter guys!
Last edited:
Sorry cant help you ask some members at encyde.se we are a Xbox Community with chat, forums and gaming weekends :D